Intermittent errors on the public platform

Incident Report for figshare.com

Resolved

This incident has been resolved.
Posted Oct 17, 2025 - 14:54 EEST

Monitoring

A sudden traffic spike has caused intermittent errors in our public platform. We have identified the source of requests and we have implemented firewall rules to regulate the inflow of traffic. We are monitoring the results.
Posted Oct 17, 2025 - 14:22 EEST

Investigating

We are currently investigating this issue.
Posted Oct 17, 2025 - 14:13 EEST
This incident affected: Systems (Website).